Cross-site Scripting (XSS) Affecting python2.7 package, versions <2.7.2-8


0.0
low

Snyk CVSS

    Attack Complexity High
NVD  low
Red Hat  low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN9-PYTHON27-306571
  • published 27 Jun 2012
  • disclosed 27 Jun 2012

How to fix?

Upgrade Debian:9 python2.7 to version 2.7.2-8 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream python2.7 package. See How to fix? for Debian:9 relevant versions.

The list_directory function in Lib/SimpleHTTPServer.py in SimpleHTTPServer in Python before 2.5.6c1, 2.6.x before 2.6.7 rc2, and 2.7.x before 2.7.2 does not place a charset parameter in the Content-Type HTTP header, which makes it easier for remote attackers to conduct cross-site scripting (XSS) attacks against Internet Explorer 7 via UTF-7 encoding.