Numeric Errors Affecting python2.7 package, versions <2.7-1


low

Snyk CVSS

    Attack Complexity Low
NVD  medium
Red Hat  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN9-PYTHON27-306583
  • published 27 May 2010
  • disclosed 27 May 2010

How to fix?

Upgrade Debian:9 python2.7 to version 2.7-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python2.7 package and not the python2.7 package as distributed by Debian:9. See How to fix? for Debian:9 relevant fixed versions and status.

Multiple integer overflows in audioop.c in the audioop module in Python 2.6, 2.7, 3.1, and 3.2 allow context-dependent attackers to cause a denial of service (application crash) via a large fragment, as demonstrated by a call to audioop.lin2lin with a long string in the first argument, leading to a buffer overflow. NOTE: this vulnerability exists because of an incorrect fix for CVE-2008-3143.5.