CVE-2010-3492 Affecting python2.7 package, versions <2.7.8-11


low

Snyk CVSS

    Attack Complexity Low
NVD  medium
Red Hat  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN9-PYTHON27-306610
  • published 19 Oct 2010
  • disclosed 19 Oct 2010

How to fix?

Upgrade Debian:9 python2.7 to version 2.7.8-11 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python2.7 package and not the python2.7 package as distributed by Debian:9. See How to fix? for Debian:9 relevant fixed versions and status.

The asyncore module in Python before 3.2 does not properly handle unsuccessful calls to the accept function, and does not have accompanying documentation describing how daemon applications should handle unsuccessful calls to the accept function, which makes it easier for remote attackers to conduct denial of service attacks that terminate these applications via network connections.