Improper Input Validation Affecting python2.7 package, versions <2.7.13-2+deb9u4


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
2.99% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-PYTHON27-584362
  • published14 Jul 2020
  • disclosed13 Jul 2020

Introduced: 13 Jul 2020

CVE-2019-20907  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:9 python2.7 to version 2.7.13-2+deb9u4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python2.7 package and not the python2.7 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

In Lib/tarfile.py in Python through 3.8.3, an attacker is able to craft a TAR archive leading to an infinite loop when opened by tarfile.open, because _proc_pax lacks header validation.

References

CVSS Base Scores

version 3.1