Improper Input Validation Affecting quagga package, versions <0.99.6-5


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.74% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-QUAGGA-319750
  • published12 Apr 2007
  • disclosed12 Apr 2007

Introduced: 12 Apr 2007

CVE-2007-1995  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:9 quagga to version 0.99.6-5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quagga package and not the quagga package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

bgpd/bgp_attr.c in Quagga 0.98.6 and earlier, and 0.99.6 and earlier 0.99 versions, does not validate length values in the MP_REACH_NLRI and MP_UNREACH_NLRI attributes, which allows remote attackers to cause a denial of service (daemon crash or exit) via crafted UPDATE messages that trigger an assertion error or out of bounds read.

CVSS Base Scores

version 3.1