Missing Authentication for Critical Function Affecting arianna package, versions <25.12.3-2


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.16% (6th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-ARIANNA-16242228
  • published25 Apr 2026
  • disclosed24 Apr 2026

Introduced: 24 Apr 2026

CVE-2026-42095  (opens in a new tab)
CWE-306  (opens in a new tab)

How to fix?

Upgrade Debian:unstable arianna to version 25.12.3-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream arianna package and not the arianna package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

bookserver in KDE Arianna before 26.04.1 allows attackers to read files over a socket connection by guessing a URL.