CVE-2023-50966 Affecting erlang-jose package, versions <1.11.10-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.89% (55th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-ERLANGJOSE-6476007
  • published22 Mar 2024
  • disclosed19 Mar 2024

Introduced: 19 Mar 2024

CVE-2023-50966  (opens in a new tab)

How to fix?

Upgrade Debian:unstable erlang-jose to version 1.11.10-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream erlang-jose package and not the erlang-jose package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

erlang-jose (aka JOSE for Erlang and Elixir) through 1.11.6 allow attackers to cause a denial of service (CPU consumption) via a large p2c (aka PBES2 Count) value in a JOSE header.