Access Restriction Bypass Affecting eterm package, versions <0.9.4.0debian1-2.1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.31% (23rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-ETERM-293621
  • published7 Apr 2008
  • disclosed7 Apr 2008

Introduced: 7 Apr 2008

CVE-2008-1692  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Debian:unstable eterm to version 0.9.4.0debian1-2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream eterm package and not the eterm package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Eterm 0.9.4 opens a terminal window on :0 if -display is not specified and the DISPLAY environment variable is not set, which might allow local users to hijack X11 connections. NOTE: realistic attack scenarios require that the victim enters a command on the wrong machine.

CVSS Base Scores

version 3.1