CVE-2026-48684 Affecting fastnetmon package, versions <1.2.9-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.26% (19th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-FASTNETMON-17089138
  • published29 May 2026
  • disclosed26 May 2026

Introduced: 26 May 2026

CVE-2026-48684  (opens in a new tab)

How to fix?

Upgrade Debian:unstable fastnetmon to version 1.2.9-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream fastnetmon package and not the fastnetmon package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

FastNetMon Community Edition through 1.2.9 contains an out-of-bounds read in the NetFlow v9 options template parser. In process_netflow_v9_options_template() (src/netflow_plugin/netflow_v9_collector.cpp), the scope parsing loop (lines 224-229) iterates until scopes_offset reaches the attacker-controlled option_scope_length value, reading netflow9_template_flowset_record_t structures at each step. No bounds check validates that (zone_address + scopes_offset + sizeof(record)) stays within the flowset. The same issue affects the options field loop (lines 241-257) with option_length. Furthermore, option_scope_length is not validated to be a multiple of sizeof(netflow9_template_flowset_record_t), potentially causing misaligned reads. An attacker can trigger reads past the end of the UDP packet buffer.

CVSS Base Scores

version 3.1