Out-of-Bounds Affecting firebird4.0 package, versions <4.0.7.3271.ds6-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.46% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-FIREBIRD40-16104626
  • published19 Apr 2026
  • disclosed17 Apr 2026

Introduced: 17 Apr 2026

CVE-2026-27890  (opens in a new tab)
CWE-119  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Debian:unstable firebird4.0 to version 4.0.7.3271.ds6-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream firebird4.0 package and not the firebird4.0 package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and 3.0.14, when processing CNCT_specific_data segments during authentication, the server assumes segments arrive in strictly ascending order. If segments arrive out of order, the Array class's grow() method computes a negative size value, causing a SIGSEGV crash. An unauthenticated attacker who knows only the server's IP and port can exploit this to crash the server. This issue has been fixed in versions 5.0.4, 4.0.7 and 3.0.14.

CVSS Base Scores

version 3.1