Out-of-bounds Read The advisory has been revoked - it doesn't affect any version of package freerdp  (opens in a new tab)


Threat Intelligence

EPSS
2.28% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-FREERDP-15257279
  • published11 Feb 2026
  • disclosed29 May 2020

Introduced: 29 May 2020

CVE-2020-11019  (opens in a new tab)
CWE-125  (opens in a new tab)

Amendment

The Debian security team deemed this advisory irrelevant for Debian:unstable.

NVD Description

Note: Versions mentioned in the description apply only to the upstream freerdp package and not the freerdp package as distributed by Debian.

In FreeRDP less than or equal to 2.0.0, when running with logger set to "WLOG_TRACE", a possible crash of application could occur due to a read of an invalid array index. Data could be printed as string to local terminal. This has been fixed in 2.1.0.