Double Free Affecting gettext package, versions <0.19.8.1-9


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
4.26% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-GETTEXT-320227
  • published2 Dec 2018
  • disclosed29 Oct 2018

Introduced: 29 Oct 2018

CVE-2018-18751  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade Debian:unstable gettext to version 0.19.8.1-9 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gettext package and not the gettext package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

An issue was discovered in GNU gettext 0.19.8. There is a double free in default_add_message in read-catalog.c, related to an invalid free in po_gram_parse in po-gram-gen.y, as demonstrated by lt-msgfmt.