Improper Validation of Array Index Affecting gitsign package, versions <0.16.0-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.11% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-GITSIGN-16749826
  • published18 May 2026
  • disclosed15 May 2026

Introduced: 15 May 2026

CVE-2026-44310  (opens in a new tab)
CWE-129  (opens in a new tab)
CWE-390  (opens in a new tab)

How to fix?

Upgrade Debian:unstable gitsign to version 0.16.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gitsign package and not the gitsign package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Gitsign is a keyless Sigstore to signing tool for Git commits with your a GitHub / OIDC identity. From 0.4.0 to before 0.15.0, CertVerifier.Verify() in pkg/git/verifier.go unconditionally dereferences certs[0] after sd.GetCertificates() without checking the slice length. A CMS/PKCS7 signed message with an empty certificate set is a structurally valid DER payload; GetCertificates() returns an empty slice with no error, causing an immediate index-out-of-range panic. On the gitsign --verify code path (the GPG-compatible mode invoked by git verify-commit), the panic is silently recovered by internal/io/streams.go's Wrap() function, which returns nil instead of an error. main.go then exits with code 0, causing exit-code-only verification callers to interpret the failed verification as success. This vulnerability is fixed in 0.15.0.