CVE-2023-0475 The advisory has been revoked - it doesn't affect any version of package golang-github-hashicorp-go-getter  (opens in a new tab)


Threat Intelligence

EPSS
0.45% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-GOLANGGITHUBHASHICORPGOGETTER-3323797
  • published17 Feb 2023
  • disclosed16 Feb 2023

Introduced: 16 Feb 2023

CVE-2023-0475  (opens in a new tab)

Amendment

The Debian security team deemed this advisory irrelevant for Debian:unstable.

NVD Description

Note: Versions mentioned in the description apply only to the upstream golang-github-hashicorp-go-getter package and not the golang-github-hashicorp-go-getter package as distributed by Debian.

HashiCorp go-getter up to 1.6.2 and 2.1.1 is vulnerable to decompression bombs. Fixed in 1.7.0 and 2.2.0.