Resource Exhaustion Affecting graphql-core package, versions <3.2.12-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.6% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-GRAPHQLCORE-21479308
  • published23 Oct 2026
  • disclosed22 Oct 2026

Introduced: 22 Oct 2026

NewCVE-2026-75507  (opens in a new tab)
CWE-400  (opens in a new tab)
CWE-407  (opens in a new tab)

How to fix?

Upgrade Debian:unstable graphql-core to version 3.2.12-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream graphql-core package and not the graphql-core package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

GraphQL-core is a Python port of the GraphQL.js reference implementation. From 3.0.0 until 3.2.12 and 3.3.0rc1, the OverlappingFieldsCanBeMerged rule in specified_rules repeatedly compares fields that share response names and recursively re-compares flattened inline fragments during the validation phase. The prior named-fragment memoization does not cover this path, so nested repeated inline fragments can drive quadratic and worst-case O(n²·m²) CPU work before any resolver or AST-based depth or complexity control runs. An unauthenticated remote attacker can submit a shallow, highly compressible GraphQL query that pins a worker process and can saturate a multi-worker service. This issue is fixed in versions 3.2.12 and 3.3.0rc1.