Out-of-Bounds Affecting hivex package, versions <1.3.11-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.63% (46th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-HIVEX-309707
  • published8 Dec 2014
  • disclosed8 Dec 2014

Introduced: 8 Dec 2014

CVE-2014-9273  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:unstable hivex to version 1.3.11-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hivex package and not the hivex package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

lib/handle.c in Hivex before 1.3.11 allows local users to execute arbitrary code and gain privileges via a small hive files, which triggers an out-of-bounds read or write.

CVSS Base Scores

version 3.1