CVE-2026-104594 Affecting libosmocore package, versions <1.14.2-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.24% (16th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-LIBOSMOCORE-21755234
  • published27 Oct 2026
  • disclosed26 Oct 2026

Introduced: 26 Oct 2026

NewCVE-2026-104594  (opens in a new tab)

How to fix?

Upgrade Debian:unstable libosmocore to version 1.14.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libosmocore package and not the libosmocore package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

libosmocore through 1.14.1 contains out-of-bounds reads in the IPA CCM identity-tag parsers in src/gsm/ipa.c. This allows a remote attacker to obtain sensitive information.