NULL Pointer Dereference Affecting libsass package, versions <3.5.4-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.63% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-LIBSASS-296025
  • published4 Jun 2018
  • disclosed4 Jun 2018

Introduced: 4 Jun 2018

CVE-2018-11695  (opens in a new tab)
CWE-476  (opens in a new tab)

How to fix?

Upgrade Debian:unstable libsass to version 3.5.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsass package and not the libsass package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

An issue was discovered in LibSass <3.5.3. A NULL pointer dereference was found in the function Sass::Expand::operator which could be leveraged by an attacker to cause a denial of service (application crash) or possibly have unspecified other impact.