CVE-2006-5876 Affecting libsoup package, versions <2.2.98-2


Severity

Recommended
medium

Based on Debian security rating.

Threat Intelligence

EPSS
2.76% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-LIBSOUP-21483476
  • published23 Oct 2026
  • disclosed16 Jan 2007

Introduced: 16 Jan 2007

CVE-2006-5876  (opens in a new tab)

How to fix?

Upgrade Debian:unstable libsoup to version 2.2.98-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsoup package and not the libsoup package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

The soup_headers_parse function in soup-headers.c for libsoup HTTP library before 2.2.99 allows remote attackers to cause a denial of service (crash) via malformed HTTP headers, probably involving missing fields or values.

CVSS Base Scores

version 3.1