Numeric Errors Affecting libsoup package, versions <2.2.105-4


Severity

Recommended
medium

Based on Debian security rating.

Threat Intelligence

EPSS
4.02% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-LIBSOUP-21483478
  • published23 Oct 2026
  • disclosed14 Mar 2009

Introduced: 14 Mar 2009

CVE-2009-0585  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Debian:unstable libsoup to version 2.2.105-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsoup package and not the libsoup package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Integer overflow in the soup_base64_encode function in soup-misc.c in libsoup 2.x.x before 2.2.x, and 2.x before 2.24, allows context-dependent attackers to execute arbitrary code via a long string that is converted to a base64 representation.

CVSS Base Scores

version 3.1