Improper Input Validation Affecting ocaml package, versions <4.00.0~beta2-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
2.65% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-OCAML-310227
  • published8 Feb 2012
  • disclosed8 Feb 2012

Introduced: 8 Feb 2012

CVE-2012-0839  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:unstable ocaml to version 4.00.0~beta2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ocaml package and not the ocaml package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

OCaml 3.12.1 and earlier computes hash values without restricting the ability to trigger hash collisions predictably, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted input to an application that maintains a hash table.

CVSS Base Scores

version 3.1