Improper Authentication Affecting openvpn-auth-oauth2 package, versions <1.27.3-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.44% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-OPENVPNAUTHOAUTH2-16638694
  • published11 May 2026
  • disclosed8 May 2026

Introduced: 8 May 2026

CVE-2026-41070  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Debian:unstable openvpn-auth-oauth2 to version 1.27.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openvpn-auth-oauth2 package and not the openvpn-auth-oauth2 package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

openvpn-auth-oauth2 is a plugin/management interface client for OpenVPN server to handle an OIDC based single sign-on (SSO) auth flows. From version 1.26.3 to before version 1.27.3, when openvpn-auth-oauth2 is deployed in the experimental plugin mode (shared library loaded by OpenVPN via the plugin directive), clients that do not support WebAuth/SSO (e.g., the openvpn CLI on Linux) are incorrectly admitted to the VPN despite being denied by the authentication logic. The default management-interface mode is not affected because it does not use the OpenVPN plugin return-code mechanism. This issue has been patched in version 1.27.3.