Return of Wrong Status Code Affecting pam-pkcs11 package, versions <0.6.13-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.23% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-PAMPKCS11-8689998
  • published8 Feb 2025
  • disclosed16 Jan 2026

Introduced: 8 Feb 2025

CVE-2025-24531  (opens in a new tab)
CWE-393  (opens in a new tab)

How to fix?

Upgrade Debian:unstable pam-pkcs11 to version 0.6.13-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pam-pkcs11 package and not the pam-pkcs11 package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

In OpenSC pam_pkcs11 before 0.6.13, pam_sm_authenticate() wrongly returns PAM_IGNORE in many error situations (such as an error triggered by a smartcard before login), allowing authentication bypass.

CVSS Base Scores

version 3.1