Arbitrary Code Injection Affecting pdm package, versions <2.27.0-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.19% (8th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-PDM-18520183
  • published5 Aug 2026
  • disclosed4 Aug 2026

Introduced: 4 Aug 2026

CVE-2026-47781  (opens in a new tab)
CWE-94  (opens in a new tab)
CWE-829  (opens in a new tab)

How to fix?

Upgrade Debian:unstable pdm to version 2.27.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pdm package and not the pdm package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

PDM is a Python package and dependency manager. In versions up to and including 2.26.9, PDM automatically loads project-local plugins from a .pdm-plugins directory during initialization, allowing an attacker-controlled file in an untrusted repository checkout to execute arbitrary Python code before any command is parsed. This happens because load_plugins() runs during Core.init() and adds .pdm-plugins via site.addsitedir(), which processes .pth files and immediately executes any line beginning with import, so the code runs with the privileges of the user invoking pdm and even a benign command such as pdm --version triggers it (making the impact strongest in CI, automation, and privileged contexts). The issue is fixed in version 2.27.0.