Protection Mechanism Failure Affecting php-twig package, versions <3.26.0-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.62% (47th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-PHPTWIG-16896368
  • published27 May 2026
  • disclosed14 Jul 2026

Introduced: 27 May 2026

CVE-2026-46634  (opens in a new tab)
CWE-693  (opens in a new tab)

How to fix?

Upgrade Debian:unstable php-twig to version 3.26.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-twig package and not the php-twig package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Twig is a template language for PHP. From 3.9.0 until 3.26.0, template_from_string() compiles an inner template under a synthesized string_template<hash> name that can fall outside a SourcePolicyInterface sandbox decision, allowing a sandboxed template that can call template_from_string and include to render an inner template without security policy enforcement. This issue is fixed in version 3.26.0.

CVSS Base Scores

version 3.1