Incorrect Default Permissions Affecting pipewire package, versions <1.0.2-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.28% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-PIPEWIRE-6226955
  • published3 Feb 2024
  • disclosed24 Jan 2024

Introduced: 24 Jan 2024

CVE-2022-4964  (opens in a new tab)
CWE-276  (opens in a new tab)

How to fix?

Upgrade Debian:unstable pipewire to version 1.0.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pipewire package and not the pipewire package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Ubuntu's pipewire-pulse in snap grants microphone access even when the snap interface for audio-record is not set.

CVSS Base Scores

version 3.1