CVE-2026-3029 Affecting pymupdf package, versions <1.26.7+ds1-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.37% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-PYMUPDF-15745174
  • published22 Mar 2026
  • disclosed19 Mar 2026

Introduced: 19 Mar 2026

CVE-2026-3029  (opens in a new tab)

How to fix?

Upgrade Debian:unstable pymupdf to version 1.26.7+ds1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pymupdf package and not the pymupdf package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

A path traversal and arbitrary file write vulnerability exist in the embedded get function in 'main.py' in PyMuPDF version, 1.26.5.