Resource Exhaustion Affecting python-pykmip package, versions <0.7.0-3


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.29% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-PYTHONPYKMIP-260007
  • published20 Dec 2018
  • disclosed20 Dec 2018

Introduced: 20 Dec 2018

CVE-2018-1000872  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Debian:unstable python-pykmip to version 0.7.0-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-pykmip package and not the python-pykmip package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

OpenKMIP PyKMIP version All versions before 0.8.0 contains a CWE 399: Resource Management Errors (similar issue to CVE-2015-5262) vulnerability in PyKMIP server that can result in DOS: the server can be made unavailable by one or more clients opening all of the available sockets. This attack appear to be exploitable via A client or clients open sockets with the server and then never close them. This vulnerability appears to have been fixed in 0.8.0.