Improper Verification of Cryptographic Signature Affecting rclone package, versions <1.75.2-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.15% (5th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-RCLONE-21709403
  • published26 Oct 2026
  • disclosed25 Oct 2026

Introduced: 25 Oct 2026

NewCVE-2026-116189  (opens in a new tab)
CWE-347  (opens in a new tab)

How to fix?

Upgrade Debian:unstable rclone to version 1.75.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rclone package and not the rclone package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

rclone from 1.55.0 before 1.75.2 contains a signature verification bypass in stable selfupdate that trusts checksums from unsigned bytes preceding the PGP-clearsigned SHA256SUMS block. Attackers controlling the release distribution path can prepend an unsigned checksum line matching a malicious archive, causing selfupdate to install an attacker-controlled rclone executable.

CVSS Base Scores

version 3.1