Improper Authentication The advisory has been revoked - it doesn't affect any version of package ruby-omniauth-auth0  (opens in a new tab)


Threat Intelligence

EPSS
0.8% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-RUBYOMNIAUTHAUTH0-1021155
  • published23 Oct 2020
  • disclosed21 Oct 2020

Introduced: 21 Oct 2020

CVE-2020-15240  (opens in a new tab)
CWE-287  (opens in a new tab)
CWE-347  (opens in a new tab)

Amendment

The Debian security team deemed this advisory irrelevant for Debian:unstable.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-omniauth-auth0 package and not the ruby-omniauth-auth0 package as distributed by Debian.

omniauth-auth0 (rubygems) versions >= 2.3.0 and < 2.4.1 improperly validate the JWT token signature when using the jwt_validator.verify method. Improper validation of the JWT token signature can allow an attacker to bypass authentication and authorization. You are affected by this vulnerability if all of the following conditions apply: 1. You are using omniauth-auth0. 2. You are using JWTValidator.verify method directly OR you are not authenticating using the SDK’s default Authorization Code Flow. The issue is patched in version 2.4.1.