Insufficient Control of Network Message Volume (Network Amplification) Affecting rust-ntpd package, versions <1.6.2-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.33% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-RUSTNTPD-12253228
  • published31 Aug 2025
  • disclosed29 Aug 2025

Introduced: 29 Aug 2025

CVE-2025-58066  (opens in a new tab)
CWE-406  (opens in a new tab)

How to fix?

Upgrade Debian:unstable rust-ntpd to version 1.6.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rust-ntpd package and not the rust-ntpd package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

nptd-rs is a tool for synchronizing your computer's clock, implementing the NTP and NTS protocols. In versions between 1.2.0 and 1.6.1 inclusive servers which allow non-NTS traffic are affected by a denial of service vulnerability, where an attacker can induce a message storm between two NTP servers running ntpd-rs. Client-only configurations are not affected. Affected users are recommended to upgrade to version 1.6.2 as soon as possible.