XML External Entity (XXE) Injection Affecting simple-xml package, versions <2.7.1-3


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
4.66% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-SIMPLEXML-264625
  • published17 Nov 2017
  • disclosed17 Nov 2017

Introduced: 17 Nov 2017

CVE-2017-1000190  (opens in a new tab)
CWE-611  (opens in a new tab)

How to fix?

Upgrade Debian:unstable simple-xml to version 2.7.1-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream simple-xml package and not the simple-xml package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

SimpleXML (latest version 2.7.1) is vulnerable to an XXE vulnerability resulting SSRF, information disclosure, DoS and so on.

CVSS Base Scores

version 3.1