Not Failing Securely ('Failing Open') Affecting snuffleupagus package, versions <0.13.0-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.71% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-SNUFFLEUPAGUS-15170979
  • published3 Feb 2026
  • disclosed8 Jan 2026

Introduced: 8 Jan 2026

CVE-2026-22034  (opens in a new tab)
CWE-636  (opens in a new tab)

How to fix?

Upgrade Debian:unstable snuffleupagus to version 0.13.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream snuffleupagus package and not the snuffleupagus package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Snuffleupagus is a module that raises the cost of attacks against website by killing bug classes and providing a virtual patching system. On deployments of Snuffleupagus prior to version 0.13.0 with the non-default upload validation feature enabled and configured to use one of the upstream validation scripts based on Vulcan Logic Disassembler (VLD) while the VLD extension is not available to the CLI SAPI, all files from multipart POST requests are evaluated as PHP code. The issue was fixed in version 0.13.0.

CVSS Base Scores

version 3.1