Cross-site Scripting (XSS) Affecting telegram-desktop package, versions <5.7.2+ds-6


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.14% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-TELEGRAMDESKTOP-20653270
  • published9 Oct 2026
  • disclosed21 Sept 2026

Introduced: 21 Sep 2026

CVE-2026-94488  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:unstable telegram-desktop to version 5.7.2+ds-6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream telegram-desktop package and not the telegram-desktop package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Telegram Desktop before 6.9.4 allows XSS in the HTML exporter. (The first fixed stable version is 7.0.1.) This occurs in button.text.toUtf8 in export_output_html.cpp. Exploitation cannot occur unless HTML export was used by a victim. However, the exploit payload can be exported if a message were forwarded into a group by a member (it is not necessary for the message author to be a member of a group).