XML External Entity (XXE) Injection The advisory has been revoked - it doesn't affect any version of package tika  (opens in a new tab)


Threat Intelligence

EPSS
7.54% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-TIKA-606681
  • published19 Aug 2020
  • disclosed9 Oct 2018

Introduced: 9 Oct 2018

CVE-2018-11796  (opens in a new tab)
CWE-611  (opens in a new tab)

Amendment

The Debian security team deemed this advisory irrelevant for Debian:unstable.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tika package and not the tika package as distributed by Debian.

In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.