Information Exposure Affecting wlc package, versions <2.2.1-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.08% (1st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-WLC-20073588
  • published24 Sept 2026
  • disclosed22 Sept 2026

Introduced: 22 Sep 2026

CVE-2026-62364  (opens in a new tab)
CWE-200  (opens in a new tab)
CWE-349  (opens in a new tab)

How to fix?

Upgrade Debian:unstable wlc to version 2.2.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream wlc package and not the wlc package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

wlc is a Weblate command-line client using Weblate's REST API. Prior to 2.0.1, automatically discovered configuration from .weblate, .weblate.ini, or weblate.ini can select the API URL while an unscoped API token is supplied through WLC_KEY or --key without a matching WLC_URL or --url. When wlc runs in an untrusted repository, pull request checkout, or directory with untrusted ancestor configuration, it can send the token to an attacker-controlled project-configured URL. URL-scoped keys in [keys] are not affected. This issue is fixed in version 2.0.1.