CVE-2026-89136 Affecting wolfssl package, versions <5.9.2-1.1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.38% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-WOLFSSL-20186135
  • published28 Sept 2026
  • disclosed27 Sept 2026

Introduced: 27 Sep 2026

CVE-2026-89136  (opens in a new tab)

How to fix?

Upgrade Debian:unstable wolfssl to version 5.9.2-1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream wolfssl package and not the wolfssl package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

When using RPK (Raw Public Key), the client side of a TLS 1.2, 1.3 and DTLS 1.2 connection could accept an unsolicited server_cert_type=RawPublicKey which allowed a malicious or misbehaving server to bypass authentication. RPK is off by default and only enabled in --enable-rpk OR --enable-all OR --enable-distro AKA HAVE_RPK builds.