Information Exposure Affecting yt-dlp package, versions <2026.06.09-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.32% (25th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-YTDLP-17443780
  • published24 Jun 2026
  • disclosed23 Jun 2026

Introduced: 23 Jun 2026

CVE-2026-50019  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Debian:unstable yt-dlp to version 2026.06.09-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream yt-dlp package and not the yt-dlp package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

yt-dlp is a command-line audio/video downloader. From 2023.09.24 until 2026.06.09, if curl is used as an external downloader for yt-dlp, cookies may be leaked to an unintended host upon HTTP redirect or when the host for download fragments differs from their parent manifest's. At the file download stage, the cookies are passed by yt-dlp to the file downloader via --cookie. However, unless these are loaded from a file, this operation does not activate the cookie engine. As a result, curl will send cookies with requests to domains or paths for which the cookies are not scoped. This vulnerability is fixed in 2026.06.09.