CVE-2025-30093 Affecting condor package, versions <23.9.6+dfsg-2


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.36% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-CONDOR-21184603
  • published18 Oct 2026
  • disclosed27 Mar 2025

Introduced: 27 Mar 2025

CVE-2025-30093  (opens in a new tab)

How to fix?

Upgrade Echo:latest condor to version 23.9.6+dfsg-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream condor package and not the condor package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

HTCondor 23.0.x before 23.0.22, 23.10.x before 23.10.22, 24.0.x before 24.0.6, and 24.6.x before 24.6.1 allows authenticated attackers to bypass authorization restrictions.