Improper Authentication Affecting grafana-12.3-fips package, versions <12.3.11+e4


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.41% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-GRAFANA123FIPS-19643947
  • published8 Sept 2026
  • disclosed9 Jul 2026

Introduced: 9 Jul 2026

CVE-2026-55689  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Echo:latest grafana-12.3-fips to version 12.3.11+e4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream grafana-12.3-fips package and not the grafana-12.3-fips package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

OpenFGA is an authorization/permission engine built for developers. Prior to 1.18.0, OpenFGA's OIDC authenticator skipped JWT audience validation when authn.method was set to oidc, authn.oidc.issuer was configured, and authn.oidc.audience was not set, allowing a token minted for an unrelated service by the same identity provider to authenticate to OpenFGA. This issue is fixed in 1.18.0.

CVSS Base Scores

version 3.1