XML External Entity (XXE) Injection Affecting inkscape package, versions <1.2.2-2+deb12u1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.24% (16th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-INKSCAPE-21751204
  • published27 Oct 2026
  • disclosed27 Mar 2026

Introduced: 27 Mar 2026

CVE-2026-4980  (opens in a new tab)
CWE-611  (opens in a new tab)

How to fix?

Upgrade Echo:latest inkscape to version 1.2.2-2+deb12u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream inkscape package and not the inkscape package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

A local file disclosure vulnerability in the XInclude processing component of Inkscape 1.1 before 1.3 allows a remote attacker to read local files via a crafted SVG file containing malicious xi:include tags.

CVSS Base Scores

version 3.1