CVE-2024-52946 Affecting lemonldap-ng package, versions <2.16.1+ds-deb12u4


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.49% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-LEMONLDAPNG-18610995
  • published11 Aug 2026
  • disclosed18 Nov 2024

Introduced: 18 Nov 2024

CVE-2024-52946  (opens in a new tab)

How to fix?

Upgrade Echo:latest lemonldap-ng to version 2.16.1+ds-deb12u4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lemonldap-ng package and not the lemonldap-ng package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

An issue was discovered in LemonLDAP::NG before 2.20.1. An Improper Check during session refresh allows an authenticated user to raise their authentication level if the admin configured an "Adaptative authentication rule" with an increment instead of an absolute value.