OS Command Injection Affecting lemonldap-ng package, versions <2.16.1+ds-deb12u7


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
1.15% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-LEMONLDAPNG-18610999
  • published11 Aug 2026
  • disclosed17 Sept 2025

Introduced: 17 Sep 2025

CVE-2025-59518  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Echo:latest lemonldap-ng to version 2.16.1+ds-deb12u7 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lemonldap-ng package and not the lemonldap-ng package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

In LemonLDAP::NG before 2.16.7 and 2.17 through 2.21 before 2.21.3, OS command injection can occur in the Safe jail. It does not Localize _ during rule evaluation. Thus, an administrator who can edit a rule evaluated by the Safe jail can execute commands on the server.