CVE-2026-98267 Affecting linux-6.12 package, versions <6.12.113-1~deb12u1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.17% (7th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-LINUX612-21478442
  • published23 Oct 2026
  • disclosed6 Oct 2026

Introduced: 6 Oct 2026

NewCVE-2026-98267  (opens in a new tab)

How to fix?

Upgrade Echo:latest linux-6.12 to version 6.12.113-1~deb12u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-6.12 package and not the linux-6.12 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

In the Linux kernel, the following vulnerability has been resolved:

9p: Fix v9fs_issue_write() to update i_size and remote_i_size

Fix v9fs_issue_write() to update i_size and remote_i_size to the new size of the server file if we made it larger, using the start fpos and the count returned by p9_client_write() to calculate the new minimum file size.

This assumes that if the 9P server makes a short write (say it hits ENOSPC), a reduced count is returned.

CVSS Base Scores

version 3.1