CVE-2026-98421 Affecting linux-6.12 package, versions <6.12.113-1~deb12u1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.22% (12th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-LINUX612-21478543
  • published23 Oct 2026
  • disclosed14 Oct 2026

Introduced: 14 Oct 2026

NewCVE-2026-98421  (opens in a new tab)

How to fix?

Upgrade Echo:latest linux-6.12 to version 6.12.113-1~deb12u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-6.12 package and not the linux-6.12 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

In the Linux kernel, the following vulnerability has been resolved:

wifi: mac80211: require a peer station for TDLS setup confirm

It's nonsense for the setup confirm to go to station that doesn't even exist, and it hits a warning when building the frame:

WARN_ON_ONCE(!sta || !ap_sta)

Only accept WLAN_TDLS_SETUP_CONFIRM when the station is already there as a TDLS station. Need to copy the call to ieee80211_tdls_prep_mgmt_packet() since the existing WLAN_TDLS_DISCOVERY_REQUEST already falls through to it.

CVSS Base Scores

version 3.1