CVE-2026-98830 Affecting linux-6.12 package, versions <6.12.113-1~deb12u1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.2% (10th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-LINUX612-21478855
  • published23 Oct 2026
  • disclosed18 Oct 2026

Introduced: 18 Oct 2026

NewCVE-2026-98830  (opens in a new tab)

How to fix?

Upgrade Echo:latest linux-6.12 to version 6.12.113-1~deb12u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-6.12 package and not the linux-6.12 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

In the Linux kernel, the following vulnerability has been resolved:

wifi: wfx: validate MIB read length before copying to caller

wfx_hif_read_mib() copies reply->length bytes from the firmware response into the caller-provided buffer without checking that reply->length does not exceed val_len. A firmware response with a length field larger than expected overruns the caller buffer and reads past the end of the reply allocation.

Replace the dead -ENOMEM check with an active validation that reply->length fits within val_len before the memcpy.

CVSS Base Scores

version 3.1