Cross-site Scripting (XSS) Affecting mapserver package, versions *


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.25% (16th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-MAPSERVER-20044344
  • published22 Sept 2026
  • disclosed8 May 2026

Introduced: 8 May 2026

CVE-2026-42030  (opens in a new tab)
CWE-80  (opens in a new tab)

How to fix?

There is no fixed version for Echo:latest mapserver.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mapserver package and not the mapserver package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

MapServer is a system for developing web-based GIS applications. From version 6.0 to before version 8.6.2, a reflected XSS vulnerability in MapServer's WMS server allows an unauthenticated attacker to inject arbitrary HTML/JavaScript into the browser of any user who opens a crafted WMS URL. The vulnerability is triggered via FORMAT=application/openlayers combined with an unsanitized SRS parameter in WMS 1.3.0 requests. This issue has been patched in version 8.6.2.