CVE-2026-3308 Affecting mupdf package, versions <1.21.1+ds2-1+deb12u1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.22% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-MUPDF-21279854
  • published20 Oct 2026
  • disclosed31 Mar 2026

Introduced: 31 Mar 2026

CVE-2026-3308  (opens in a new tab)

How to fix?

Upgrade Echo:latest mupdf to version 1.21.1+ds2-1+deb12u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mupdf package and not the mupdf package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

An integer overflow vulnerability in 'pdf-image.c' in Artifex's MuPDF version 1.27.0 allows an attacker to maliciously craft a PDF that can trigger an integer overflow within the 'pdf_load_image_imp' function. This allows a heap out-of-bounds write that could be exploited for arbitrary code execution.