Symlink Following Affecting opam package, versions <2.1.2-1+deb12u2


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.47% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-OPAM-17978472
  • published15 Jul 2026
  • disclosed9 Sept 2026

Introduced: 15 Jul 2026

CVE-2026-57825  (opens in a new tab)
CWE-61  (opens in a new tab)

How to fix?

Upgrade Echo:latest opam to version 2.1.2-1+deb12u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opam package and not the opam package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

In the opam package before 2.5.2 for OCaml, the sandbox protection mechanism can be bypassed because symlinks are mishandled during use of .install files.