Resource Exhaustion Affecting openjpeg2 package, versions <2.5.3-2.1~deb13u1+e1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.24% (16th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ECHOLATEST-OPENJPEG2-21751312
  • published27 Oct 2026
  • disclosed9 Jul 2024

Introduced: 9 Jul 2024

CVE-2023-39328  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Echo:latest openjpeg2 to version 2.5.3-2.1~deb13u1+e1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openjpeg2 package and not the openjpeg2 package as distributed by Echo. See How to fix? for Echo:latest relevant fixed versions and status.

A vulnerability was found in OpenJPEG similar to CVE-2019-6988. This flaw allows an attacker to bypass existing protections and cause an application crash through a maliciously crafted file.

CVSS Base Scores

version 3.1